Ubuntu bug solution: Keyboard’s modifier keys aren’t working

What are modifier keys?

Alt, Control, Shift and Windows key are modifier keys. They’re mostly used in combination with other keys.

Examples: Ctrl+Alt+Delete, Alt+Tab and others…

The story:

As an owner of Zowie Celeritas I understood the hard way that my keyboard isn’t really supported by the Linux kernel.

Any modifier keys combinations don’t work.

The problem is not Ubuntu-specific, I tried Mint and Debian – problem still persists.

This is a common problem for other keyboards too, so the solution may or may not work for you.

The solution:

If your keyboard is PS/2 -> you shouldn’t have a problem to begin with. But you can still try with an adapter from PS/2 to USB, to see if your keyboard works.

If your keyboard is USB -> use a USB to PS/2 adapter. This has worked for many

If your keyboard is USB but you don’t have a PS/2 port (Zowie Celeritas and other mechanical keyboards in combination with a laptop) -> If you don’t have a USB to PS2 adapter buy the above one, else use the one provided with your keyboard. Afterwards buy this PS/2 to USB adapter or a similar one. It must be a real adapter and convert the signal.  The one I provided worked for me and many others.

Good luck and I hope you resolve this problem!

Advertisements

One comment

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s